We have moved our status notifications to DSTNY Zone Additional information can be found Here

Microsoft are investigating an O365 issue

Minor incident Web
2023-01-25 08:34 UTC · 2 hours, 27 minutes

Updates

Resolved

Microsoft have closed their incident, more details can be found here: https://status.office365.com/

Incident closed

January 25, 2023 · 11:01 UTC
Update

Microsoft are continuing to investigate

For more details see https://azure.status.microsoft/en-gb/status

We will provide another update by 11:15 UTC

January 25, 2023 · 09:17 UTC
Issue

We have a notification from Microsoft saying they are investigating O365 issues which are impacting multiple Microsoft 365 services. More info can be found in the MS admin center under MO502273.

January 25, 2023 · 08:35 UTC

← Back