We have moved our status notifications to DSTNY Zone Additional information can be found Here

Reports of Issues with calls

Major incident SBCs - North America
2023-05-24 19:31 UTC · 1 hour, 40 minutes

Updates

Resolved

This issue is now resolved.

May 24, 2023 · 21:12 UTC
Monitoring

The issue has been isolated and services are beginning to be restored.

May 24, 2023 · 20:39 UTC
Update

We are currently investigating an issue that has been identified by our platform team.

May 24, 2023 · 19:54 UTC
Investigating

Reports of audio issues currently being investigated.

May 24, 2023 · 19:31 UTC

← Back