We have moved our status notifications to DSTNY Zone Additional information can be found Here

Reports of some failed outbound calls

Minor incident SBCs - Europe SBCs - North America SBCs - APAC
2023-06-05 10:37 UTC · 3 hours, 52 minutes

Updates

Resolved

No further call issues identified

June 5, 2023 · 14:29 UTC
Monitoring

No further call failures. Engineers are actively monitoring.

June 5, 2023 · 14:07 UTC
Investigating

Engineers continue to investigate

June 5, 2023 · 13:01 UTC
Monitoring

The issue has been identified and steps taken. We are monitoring the incident.

June 5, 2023 · 10:37 UTC

← Back