We have moved our status notifications to DSTNY Zone Additional information can be found Here

Reports of the 'services' tab in the portal not loading templates

Minor incident Web
2023-07-31 08:23 UTC · 10 minutes

Updates

Resolved

This is now resolved

July 31, 2023 · 08:33 UTC
Investigating

Selecting the Services tab in the portal does may not load the templates. Does not effect calling.

July 31, 2023 · 08:23 UTC

← Back