We have moved our status notifications to DSTNY Zone Additional information can be found Here

Reports of failed outbound calls

Minor incident SBCs - Europe SBCs - North America SBCs - APAC
2023-08-29 20:18 UTC · 29 minutes

Updates

Resolved

This incident is now marked as resolved

August 29, 2023 · 20:47 UTC
Monitoring

We believe the issue to be resolved and are now monitoring the situation

August 29, 2023 · 20:39 UTC
Monitoring

We are actively monitoring reports of unsuccessful outbound call attempts for specific accounts.

August 29, 2023 · 20:18 UTC

← Back