We have moved our status notifications to DSTNY Zone Additional information can be found Here

Microsoft Issue: Failing outbound Teams Calls

Minor incident SBCs - North America
2023-09-14 14:02 UTC · 30 minutes

Updates

Resolved

This issue has now been resolved

September 14, 2023 · 14:32 UTC
Investigating

We are monitoring issues reported for failed Teams calls via direct routing. This appears to be an issue on Microsoft’s end. Issue related to outbound calls in the American regions,

September 14, 2023 · 14:02 UTC

← Back