We have moved our status notifications to DSTNY Zone Additional information can be found Here

CallToTeams GO Outbound call Failures

Minor incident SBCs - Europe SBCs - North America SBCs - APAC
2023-12-21 10:44 UTC · 23 hours, 5 minutes

Updates

Resolved

This issue has been resolved and all GO application should be able to make complete inbound and outbound calls

December 22, 2023 · 09:49 UTC
Investigating

We are investigating an issue where some CalltoTeams GO application calls are failing to make outbound calls on selected accounts.

December 21, 2023 · 10:44 UTC

← Back